Home  >  Article  >  Java  >  How to calculate the sum of a sequence in java

How to calculate the sum of a sequence in java

王林
王林forward
2019-11-25 17:55:016070browse

How to calculate the sum of a sequence in java

Title description:

Input n and a, find a aa aaa...aa...a (n a), for example, when n=3, a=2 , the result of 2 22 222 is 246.

java related video tutorial: java teaching video

Input:

contains two integers, n and a, the meaning is as above, you can assume n and a are both non-negative integers less than 10

Output:

Output the sum of the first n terms, occupy a separate line

Sample input:

3 2

Sample output:

246

Program code:

import java.util.*;
public class Main
{
	public static void main(String[] args)
	{
		Scanner input=new Scanner(System.in);
		int n=input.nextInt();
		int x=input.nextInt();
		int sum=0,b=x;
		for(int i=1;i<=n;i++)
		{
			sum+=x;
			x=x*10+b;
		}
		System.out.println(sum);
	}
}

For more related articles, please visit: Introduction to java development

The above is the detailed content of How to calculate the sum of a sequence in java. For more information, please follow other related articles on the PHP Chinese website!

Statement:
This article is reproduced at:csdn.net. If there is any infringement, please contact admin@php.cn delete