search
HomeDatabaseMysql TutorialVOIP的配置举例

VOIP的配置举例

Jun 07, 2016 pm 03:11 PM
centercomplexConfiguration

复杂的VOIP 配置 一、 拓扑图 、中心 Zongbu#sh run Building configuration... Current configuration : 2216 bytes ! version 12.2 service timestamps debug uptime service timestamps log uptime no service password-encryption ! hostname Zongbu ! en

复杂的VOIP配置

一、 拓扑图

、中心

Zongbu#sh run

Building configuration...

Current configuration : 2216 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Zongbu

!

enable password cisco

!

!

class-map match-all voice

match access-group 102

!

access-list 102 permit udp any any range 16384 32767

access-list 102 permit tcp any any eq 1720

access-list 102 permit tcp any eq 1720 any

!

policy-map qos

class voice

priority 40

class class-default

fair-queue

!

voice-card 1

!

ip subnet-zero

!

!

no ip domain-lookup

!

!

!

!

!

!

!

!

!

controller E1 1/0

framing NO-CRC4

ds0-group 0 timeslots 17-31 type r2-digital r2-compelled

ds0-group 1 timeslots 1-15 type r2-digital r2-compelled

cas-custom 0

unused-abcd 0 0 1 1

country china

dnis-digits min 4 max 8

cas-custom 1

unused-abcd 0 0 1 1

country china

dnis-digits min 4 max 8

!

!

!

!

interface FastEthernet0/0

ip address 10.22.110.248 255.255.255.0

ip rip send version 2

duplex auto

speed auto

!

interface Serial0/0

description Connected to Fenzhi1

ip address 10.22.118.9 255.255.255.252

service-policy output qos

!

interface Serial0/1

description Connected to Fenzhi2

ip address 10.22.118.13 255.255.255.252

service-policy output qos

!

router ospf 100

log-adjacency-changes

redistribute static subnets

redistribute rip subnets

network 10.22.110.248 0.0.0.0 area 0

network 10.22.118.9 0.0.0.0 area 0

network 10.22.118.13 0.0.0.0 area 0

!

router rip

version 2

redistribute ospf 100 metric 2

network 10.0.0.0

default-metric 2

!

ip classless

ip route 10.0.0.0 255.0.0.0 10.22.110.253

ip route 10.22.108.0 255.255.255.0 10.22.110.254

ip route 10.22.109.0 255.255.255.0 10.22.110.254

ip http server

ip pim bidir-enable

!

!

call rsvp-sync

!

voice-port 1/0:0

!

voice-port 1/0:1

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 10 voip

description Phone to Fenzhi1

destination-pattern 6964....

session target ipv4:10.22.118.10

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

fax rate 9600

!

dial-peer voice 20 voip

description Phone to Fenzhi2

destination-pattern 6962....

session target ipv4:10.22.118.14

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

fax rate 9600

!

dial-peer voice 30 pots

destination-pattern 6491....

direct-inward-dial

port 1/0:0

!

dial-peer voice 40 pots

destination-pattern 1.

direct-inward-dial

port 1/0:1

forward-digits all

!

dial-peer voice 60 pots

destination-pattern 9481....

direct-inward-dial

port 1/0:0

forward-digits all

!

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

2、分支1

Fenzhi 1#sh run

Building configuration...

Current configuration : 1161 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Fenzhi1

!

enable password cisco

!

!

!

ip subnet-zero

!

class-map match-all voice

match access-group 102

!

access-list 102 permit udp any any range 16384 32767

access-list 102 permit tcp any any eq 1720

access-list 102 permit tcp any eq 1720 any

!

policy-map qos

class voice

priority 40

class class-default

fair-queue

!

!

!

interface Ethernet0/0

ip address 10.22.115.254 255.255.255.0

half-duplex

!

interface Serial0/0

ip address 10.22.118.10 255.255.255.252

service-policy output qos

!

router ospf 100

log-adjacency-changes

network 10.22.115.254 0.0.0.0 area 0

network 10.22.118.10 0.0.0.0 area 0

!

ip classless

ip http server

ip pim bidir-enable

!

!

call rsvp-sync

!

voice-port 1/0/0

!

voice-port 1/0/1

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 10 voip

destination-pattern 6491....

session target ipv4:10.22.118.9

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

fax rate 9600

!

dial-peer voice 20 pots

preference 2

destination-pattern 6964....

port 1/0/0

!

dial-peer voice 30 pots

preference 5

destination-pattern 6964....

port 1/0/1

!

dial-peer voice 40 voip

destination-pattern 6962....

session target ipv4:10.22.118.14

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

fax rate 9600

!

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

!

end
Statement
The content of this article is voluntarily contributed by netizens, and the copyright belongs to the original author. This site does not assume corresponding legal responsibility. If you find any content suspected of plagiarism or infringement, please contact admin@php.cn
MySQL's Role: Databases in Web ApplicationsMySQL's Role: Databases in Web ApplicationsApr 17, 2025 am 12:23 AM

The main role of MySQL in web applications is to store and manage data. 1.MySQL efficiently processes user information, product catalogs, transaction records and other data. 2. Through SQL query, developers can extract information from the database to generate dynamic content. 3.MySQL works based on the client-server model to ensure acceptable query speed.

MySQL: Building Your First DatabaseMySQL: Building Your First DatabaseApr 17, 2025 am 12:22 AM

The steps to build a MySQL database include: 1. Create a database and table, 2. Insert data, and 3. Conduct queries. First, use the CREATEDATABASE and CREATETABLE statements to create the database and table, then use the INSERTINTO statement to insert the data, and finally use the SELECT statement to query the data.

MySQL: A Beginner-Friendly Approach to Data StorageMySQL: A Beginner-Friendly Approach to Data StorageApr 17, 2025 am 12:21 AM

MySQL is suitable for beginners because it is easy to use and powerful. 1.MySQL is a relational database, and uses SQL for CRUD operations. 2. It is simple to install and requires the root user password to be configured. 3. Use INSERT, UPDATE, DELETE, and SELECT to perform data operations. 4. ORDERBY, WHERE and JOIN can be used for complex queries. 5. Debugging requires checking the syntax and use EXPLAIN to analyze the query. 6. Optimization suggestions include using indexes, choosing the right data type and good programming habits.

Is MySQL Beginner-Friendly? Assessing the Learning CurveIs MySQL Beginner-Friendly? Assessing the Learning CurveApr 17, 2025 am 12:19 AM

MySQL is suitable for beginners because: 1) easy to install and configure, 2) rich learning resources, 3) intuitive SQL syntax, 4) powerful tool support. Nevertheless, beginners need to overcome challenges such as database design, query optimization, security management, and data backup.

Is SQL a Programming Language? Clarifying the TerminologyIs SQL a Programming Language? Clarifying the TerminologyApr 17, 2025 am 12:17 AM

Yes,SQLisaprogramminglanguagespecializedfordatamanagement.1)It'sdeclarative,focusingonwhattoachieveratherthanhow.2)SQLisessentialforquerying,inserting,updating,anddeletingdatainrelationaldatabases.3)Whileuser-friendly,itrequiresoptimizationtoavoidper

Explain the ACID properties (Atomicity, Consistency, Isolation, Durability).Explain the ACID properties (Atomicity, Consistency, Isolation, Durability).Apr 16, 2025 am 12:20 AM

ACID attributes include atomicity, consistency, isolation and durability, and are the cornerstone of database design. 1. Atomicity ensures that the transaction is either completely successful or completely failed. 2. Consistency ensures that the database remains consistent before and after a transaction. 3. Isolation ensures that transactions do not interfere with each other. 4. Persistence ensures that data is permanently saved after transaction submission.

MySQL: Database Management System vs. Programming LanguageMySQL: Database Management System vs. Programming LanguageApr 16, 2025 am 12:19 AM

MySQL is not only a database management system (DBMS) but also closely related to programming languages. 1) As a DBMS, MySQL is used to store, organize and retrieve data, and optimizing indexes can improve query performance. 2) Combining SQL with programming languages, embedded in Python, using ORM tools such as SQLAlchemy can simplify operations. 3) Performance optimization includes indexing, querying, caching, library and table division and transaction management.

MySQL: Managing Data with SQL CommandsMySQL: Managing Data with SQL CommandsApr 16, 2025 am 12:19 AM

MySQL uses SQL commands to manage data. 1. Basic commands include SELECT, INSERT, UPDATE and DELETE. 2. Advanced usage involves JOIN, subquery and aggregate functions. 3. Common errors include syntax, logic and performance issues. 4. Optimization tips include using indexes, avoiding SELECT* and using LIMIT.

See all articles

Hot AI Tools

Undresser.AI Undress

Undresser.AI Undress

AI-powered app for creating realistic nude photos

AI Clothes Remover

AI Clothes Remover

Online AI tool for removing clothes from photos.

Undress AI Tool

Undress AI Tool

Undress images for free

Clothoff.io

Clothoff.io

AI clothes remover

AI Hentai Generator

AI Hentai Generator

Generate AI Hentai for free.

Hot Article

R.E.P.O. Energy Crystals Explained and What They Do (Yellow Crystal)
1 months agoBy尊渡假赌尊渡假赌尊渡假赌
R.E.P.O. Best Graphic Settings
1 months agoBy尊渡假赌尊渡假赌尊渡假赌
R.E.P.O. How to Fix Audio if You Can't Hear Anyone
1 months agoBy尊渡假赌尊渡假赌尊渡假赌
R.E.P.O. Chat Commands and How to Use Them
1 months agoBy尊渡假赌尊渡假赌尊渡假赌

Hot Tools

Zend Studio 13.0.1

Zend Studio 13.0.1

Powerful PHP integrated development environment

SublimeText3 English version

SublimeText3 English version

Recommended: Win version, supports code prompts!

Dreamweaver CS6

Dreamweaver CS6

Visual web development tools

MantisBT

MantisBT

Mantis is an easy-to-deploy web-based defect tracking tool designed to aid in product defect tracking. It requires PHP, MySQL and a web server. Check out our demo and hosting services.

VSCode Windows 64-bit Download

VSCode Windows 64-bit Download

A free and powerful IDE editor launched by Microsoft