返回 php不支持快...... 登陆

php不支持快级作用域带来的影响

移动用户-9731783 2019-08-16 11:27:15 262

1、内层变量可能会覆盖外层变量

2、用来计数的循环变量泄露为全局变量


解决方法

允许在块级作用域内声明函数。

函数声明类似于var,即会提升到全局作用域或函数作用域的头部。

同时,函数声明还会提升到所在的块级作用域的头部

最新手记推荐

• 用composer安装thinkphp框架的步骤 • 省市区接口说明 • 用thinkphp,后台新增栏目 • 管理员添加编辑删除 • 管理员添加编辑删除

全部回复(0)我要回复

暂无评论~
  • 取消 回复 发送
  • PHP中文网