• 技术文章 >开发工具 >composer

    Composer管理项目的依赖关系

    藏色散人藏色散人2020-10-09 14:04:49原创94
    下面由composer教程栏目给大家介绍Composer管理项目的依赖关系,希望对需要的朋友有所帮助!

    Composer

    如果用 Composer 来管理项目的依赖关系,只要在项目的 composer.json 文件中简单地加上对 phpunit/phpunit 的依赖关系即可。下面是一个最小化的 composer.json 文件的例子,只定义了一个对 PHPUnit 5.0 的开发时(development-time)依赖:

    {
        "require-dev": {
            "phpunit/phpunit": "5.0.*"
        }
    }

    要通过 Composer 完成系统级的安装,可以运行:

    composer global require "phpunit/phpunit=5.0.*"

    请确保 path 变量中包含有 ~/.composer/vendor/bin/。

    以上就是Composer管理项目的依赖关系的详细内容,更多请关注php中文网其它相关文章!

    本文原创发布php中文网,转载请注明出处,感谢您的尊重!
    专题推荐:Composer
    上一篇:执行 composer 抛出 Killed的解决办法 下一篇:关于Composer常见错误及其解决办法
    第13期线上培训班

    相关文章推荐

    • 教你在windows下手动安装composer• 关于composer安装包时的解决办法• phpstudy composer如何使用安装• Composer autoload 的深入理解

    全部评论我要评论

  • 取消发布评论发送
  • 1/1

    PHP中文网