PHP8.1.21版本已发布
vue8.1.21版本已发布
jquery8.1.21版本已发布

rac_grid自检提示缺少pdksh-5.2包

原创
2016-06-07 16:06:48 858浏览

原创作品,出自 深蓝的blog 博客,欢迎转载,转载时请务必注明以下出处,否则追究版权法律责任。 深蓝的blog:http://blog.csdn.net/huangyanlong/article/details/40779171 环境:CentOS 6.4 64bit、grid 64bit 错误描述:进行grid自检时报错,缺少pdksh-5.

原创作品,出自 “深蓝的blog” 博客,欢迎转载,转载时请务必注明以下出处,否则追究版权法律责任。

深蓝的blog:http://blog.csdn.net/huangyanlong/article/details/40779171

环境:CentOS 6.4 64bit、grid 64bit

错误描述:进行grid自检时报错,缺少pdksh-5.2包(前提已经安装了ksh包)

错误解决:安装pdksh包

注意:安装pdksh包时需要先卸载掉ksh包

方法:到网上下载或到CentOS5.6光盘内找到pdksh-5.2.14-36.el5.x86_64.rpm包,在每个节点下卸载默认安装的ksh包,然后安装pdksh包即可,如下安装步骤:

操作步骤:

节点1:

[root@test1 soft]# rpm -qa |grep ksh

ksh-20100621-19.el6.x86_64

[root@test1 soft]# rpm -e ksh-20100621-19.el6.x86_64

--卸载ksh

[root@test1 soft]# rpm -ivh pdksh-5.2.14-36.el5.x86_64.rpm

--安装pdksh

warning: pdksh-5.2.14-36.el5.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID e8562897: NOKEY

Preparing... ########################################### [100%]

1:pdksh ########################################### [100%]

节点2:

[root@test2 soft]# rpm -e ksh-20100621-19.el6.x86_64

[root@test2 soft]# ls

cvuqdisk-1.0.9-1.rpm pdksh-5.2.14-36.el5.x86_64.rpm

[root@test2 soft]# rpm -ivh pdksh-5.2.14-36.el5.x86_64.rpm

warning: pdksh-5.2.14-36.el5.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID e8562897: NOKEY

Preparing... ########################################### [100%]

1:pdksh ########################################### [100%]

再次执行grid自检,通过检查。

原创作品,出自 “深蓝的blog” 博客,欢迎转载,转载时请务必注明以下出处,否则追究版权法律责任。

深蓝的blog:http://blog.csdn.net/huangyanlong/article/details/40779171

声明:本文内容由网友自发贡献,版权归原作者所有,本站不承担相应法律责任。如您发现有涉嫌抄袭侵权的内容,请联系admin@php.cn核实处理。