search
HomeDatabaseMysql TutorialCISCO路由器连接ADSL之PPPoE配置

CISCO路由器连接ADSL之PPPoE配置

Jun 07, 2016 pm 03:06 PM
adslcisciscopppoerouterconnectConfiguration

CISCO 路由器 连接 ADSL之PPPoE 配置 Cisco 路由器 连接 ADSL modem的PPPoE 配置 : hostname bjsite ! ip subnet-zero no ip domain-lookup ! vpdn enable no vpdn logging ! vpdn-group 1 request-dialin protocol pppoe ! interface Ethernet0/0 ip addre


CISCO路由器连接ADSL之PPPoE配置

 

Cisco路由器连接ADSL modem的PPPoE配置

 

hostname bjsite 

ip subnet-zero 

no ip domain-lookup 

vpdn enable 

no vpdn logging 

vpdn-group 1 

request-dialin 

protocol pppoe 

interface Ethernet0/0 

ip address 192.168.0.1 255.255.255.0 

ip nat inside 

no ip mroute-cache 

interface Ethernet0/1 

no ip address 

pppoe enable 

pppoe-client dial-pool-number 1 

!   www.2cto.com  

interface Dialer1 

ip address negotiated 

ip nat outside 

ip mtu 1492 

encapsulation ppp 

no ip mroute-cache 

dialer pool 1 

dialer-group 1 

ppp authentication pap 

ppp pap sent-username dg48907653@163.gd password xxxxxxxx

ip classless 

no ip http server 

dialer-list 1 protocol ip permit 

ip nat inside source list 1 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 dialer1 

access-list 1 permit 192.168.0.0 0.0.0.255 

line con 0 

exec-timeout 0 0 

transport input none 

line vty 0 4 

login 

end

 

Cisco路由器连接ADSL WIC卡之PPPoE配置

 

vpdn-group pppoe 

request-dialin 

 

!--- we are the PPPoE client requesting to establish 

!--- a session with the aggregation unit (6400 NRP). 

 

protocol pppoe 

  www.2cto.com  

!--- internal Ethernet network.

 

interface FastEthernet0 

ip address 10.92.1.182 255.255.255.0 

ip nat inside 

 

!--- DSL interface.

interface ATM0 

no ip address 

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

hold-queue 224 in

 

!--- All defaults.

 

!--- PPPoE runs on top of AAL5SNAP, but the 

!--- encap aal5snap command is not used. 

 

interface ATM0.1 point-to-point 

pvc 1/1 

pppoe-client dial-pool-number 1

 

!--- pvc 1/1 is an example value that must be changed 

!--- to match the value used by the ISP. 

  www.2cto.com  

 

!--- The PPPoE client code ties into a dialer interface upon 

!--- which a virtual-access interface is cloned. 

interface Dialer1 

ip address negotiated 

ip mtu 1492

 

!--- Ethernet MTU default = 1500 (1492 + PPPoE headers = 1500)

 

ip nat outside 

encapsulation ppp 

dialer pool 1

 

!--- Ties to atm interface. 

 

ppp authentication chap callin 

ppp chap hostname  

ppp chap password

!--- The ISP will instruct you regarding 

!--- the type of authentication to use. 

!--- To change from PPP CHAP to PPP PAP, 

!--- replace the following three lines:

!--- ppp authentication chap callin 

!--- ppp chap hostname  

!--- ppp chap password  

!--- with the following two lines:

!--- ppp authentication pap callin

!--- ppp pap sent-username password

  www.2cto.com  

!--- For NAT we are going to overload on the Dialer1 

!--- interface and add a default route out 

!--- since dialer ip address can change. 

 

ip nat inside source list 1 interface Dialer1 overload 

ip classless 

ip route 0.0.0.0 0.0.0.0 dialer1 

no ip http server 

access-list 1 permit 10.92.1.0 0.0.0.255

Statement
The content of this article is voluntarily contributed by netizens, and the copyright belongs to the original author. This site does not assume corresponding legal responsibility. If you find any content suspected of plagiarism or infringement, please contact admin@php.cn
MySQL: BLOB and other no-sql storage, what are the differences?MySQL: BLOB and other no-sql storage, what are the differences?May 13, 2025 am 12:14 AM

MySQL'sBLOBissuitableforstoringbinarydatawithinarelationaldatabase,whileNoSQLoptionslikeMongoDB,Redis,andCassandraofferflexible,scalablesolutionsforunstructureddata.BLOBissimplerbutcanslowdownperformancewithlargedata;NoSQLprovidesbetterscalabilityand

MySQL Add User: Syntax, Options, and Security Best PracticesMySQL Add User: Syntax, Options, and Security Best PracticesMay 13, 2025 am 12:12 AM

ToaddauserinMySQL,use:CREATEUSER'username'@'host'IDENTIFIEDBY'password';Here'showtodoitsecurely:1)Choosethehostcarefullytocontrolaccess.2)SetresourcelimitswithoptionslikeMAX_QUERIES_PER_HOUR.3)Usestrong,uniquepasswords.4)EnforceSSL/TLSconnectionswith

MySQL: How to avoid String Data Types common mistakes?MySQL: How to avoid String Data Types common mistakes?May 13, 2025 am 12:09 AM

ToavoidcommonmistakeswithstringdatatypesinMySQL,understandstringtypenuances,choosetherighttype,andmanageencodingandcollationsettingseffectively.1)UseCHARforfixed-lengthstrings,VARCHARforvariable-length,andTEXT/BLOBforlargerdata.2)Setcorrectcharacters

MySQL: String Data Types and ENUMs?MySQL: String Data Types and ENUMs?May 13, 2025 am 12:05 AM

MySQloffersechar, Varchar, text, Anddenumforstringdata.usecharforfixed-Lengthstrings, VarcharerForvariable-Length, text forlarger text, AndenumforenforcingdataAntegritywithaetofvalues.

MySQL BLOB: how to optimize BLOBs requestsMySQL BLOB: how to optimize BLOBs requestsMay 13, 2025 am 12:03 AM

Optimizing MySQLBLOB requests can be done through the following strategies: 1. Reduce the frequency of BLOB query, use independent requests or delay loading; 2. Select the appropriate BLOB type (such as TINYBLOB); 3. Separate the BLOB data into separate tables; 4. Compress the BLOB data at the application layer; 5. Index the BLOB metadata. These methods can effectively improve performance by combining monitoring, caching and data sharding in actual applications.

Adding Users to MySQL: The Complete TutorialAdding Users to MySQL: The Complete TutorialMay 12, 2025 am 12:14 AM

Mastering the method of adding MySQL users is crucial for database administrators and developers because it ensures the security and access control of the database. 1) Create a new user using the CREATEUSER command, 2) Assign permissions through the GRANT command, 3) Use FLUSHPRIVILEGES to ensure permissions take effect, 4) Regularly audit and clean user accounts to maintain performance and security.

Mastering MySQL String Data Types: VARCHAR vs. TEXT vs. CHARMastering MySQL String Data Types: VARCHAR vs. TEXT vs. CHARMay 12, 2025 am 12:12 AM

ChooseCHARforfixed-lengthdata,VARCHARforvariable-lengthdata,andTEXTforlargetextfields.1)CHARisefficientforconsistent-lengthdatalikecodes.2)VARCHARsuitsvariable-lengthdatalikenames,balancingflexibilityandperformance.3)TEXTisidealforlargetextslikeartic

MySQL: String Data Types and Indexing: Best PracticesMySQL: String Data Types and Indexing: Best PracticesMay 12, 2025 am 12:11 AM

Best practices for handling string data types and indexes in MySQL include: 1) Selecting the appropriate string type, such as CHAR for fixed length, VARCHAR for variable length, and TEXT for large text; 2) Be cautious in indexing, avoid over-indexing, and create indexes for common queries; 3) Use prefix indexes and full-text indexes to optimize long string searches; 4) Regularly monitor and optimize indexes to keep indexes small and efficient. Through these methods, we can balance read and write performance and improve database efficiency.

See all articles

Hot AI Tools

Undresser.AI Undress

Undresser.AI Undress

AI-powered app for creating realistic nude photos

AI Clothes Remover

AI Clothes Remover

Online AI tool for removing clothes from photos.

Undress AI Tool

Undress AI Tool

Undress images for free

Clothoff.io

Clothoff.io

AI clothes remover

Video Face Swap

Video Face Swap

Swap faces in any video effortlessly with our completely free AI face swap tool!

Hot Article

Hot Tools

SublimeText3 Mac version

SublimeText3 Mac version

God-level code editing software (SublimeText3)

Dreamweaver CS6

Dreamweaver CS6

Visual web development tools

WebStorm Mac version

WebStorm Mac version

Useful JavaScript development tools

PhpStorm Mac version

PhpStorm Mac version

The latest (2018.2.1) professional PHP integrated development tool

mPDF

mPDF

mPDF is a PHP library that can generate PDF files from UTF-8 encoded HTML. The original author, Ian Back, wrote mPDF to output PDF files "on the fly" from his website and handle different languages. It is slower than original scripts like HTML2FPDF and produces larger files when using Unicode fonts, but supports CSS styles etc. and has a lot of enhancements. Supports almost all languages, including RTL (Arabic and Hebrew) and CJK (Chinese, Japanese and Korean). Supports nested block-level elements (such as P, DIV),