• 技术文章 >后端开发 >php教程

    pecl多版本PHP安装扩展提示重复安装?(附解决办法)

    藏色散人藏色散人2022-11-22 20:16:55转载927
    本文给大家介绍有关pecl在给多版本 PHP 安装同一个扩展的时候会提示重复安装的问题,这里有一个非常快速的解决办法,下面就给大家详细介绍,希望对需要的朋友有所帮助~

    php入门到就业线上直播课:进入学习

    不知道有人没有遇到过,pecl 在给多版本 PHP 安装同一个扩展的时候会提示重复安装。【推荐学习:PHP视频教程

    如下记录解决方法:

    1. 安装扩展

    sudo pecl -d php_suffix=8.0 install <package>

    我理解 -d php_suffix= 是指定 php 命令的后缀,例如 -d php_suffix=8.0 则为 php8.0

    2. 卸载扩展

    sudo pecl uninstall -r <package>

    加上 -r 不会删除已安装的好扩展 .so 文件

    重复以上步骤,再次安装其他 PHP 版本相同扩展就可以正常安装成功了!

    以上就是pecl多版本PHP安装扩展提示重复安装?(附解决办法)的详细内容,更多请关注php中文网其它相关文章!

    声明:本文转载于:learnku,如有侵犯,请联系admin@php.cn删除

    前端(VUE)零基础到就业课程:点击学习

    清晰的学习路线+老师随时辅导答疑

    自己动手写 PHP MVC 框架:点击学习

    快速了解MVC架构、了解框架底层运行原理

    专题推荐:php pecl Ubuntu
    上一篇:执行php exec system shell_exec没结果?一文搞定! 下一篇:自己动手写 PHP MVC 框架(40节精讲/巨细/新人进阶必看)

    相关文章推荐

    • ❤️‍🔥共22门课程,总价3725元,会员免费学• ❤️‍🔥接口自动化测试不想写代码?• PHP PECL如何安装扩展?• php7.2怎么连接oracle数据库?OCI8扩展的安装• 一文详解Rust怎么开发PHP扩展(Liunx版)• Laravel扩展推荐:vite-plugin包利用 Vite 实现热重载
    1/1

    PHP中文网