• 技术文章 >web前端 >前端问答

    react几支持ie8

    长期闲置长期闲置2022-05-05 15:06:39原创123

    在react中,支持ie8的最高版本是“react@0.14”版本,若高于这个版本都是不兼容ie8的;可以利用在“index.html”文件中加入“es5-shim.js”和“es5-sham.js”这两个文件的方法使react兼容ie8。

    本教程操作环境:windows10系统、ECMAScript 6.0版、Dell G3电脑。

    react几支持ie8

    在react的官方公布的信息中,它支持 IE8 的最高版本是 react@0.14 版本

    如果我们高于这个版本的话就会出现一些问题,而且还不能兼容我们的版本,所以在我们使用的过程中要确认使用的react版本是否有大于react0.14版本,

    当然在官方中还给出了兼容的方法,就是在我们的index.html文件中加入es5-shim.js和es5-sham.js这两个文件就可以了,

    而且我们还要确保使用的 jQuery 版本是不大于 jQuery2.0 的版本,因为在 IE8 中不支持 jQuery2.0及以上的版本。如果你是使用 bootstrap 框架的话我们的 jQuery 的版本最低要用 jQuery1.9 以上的版本。

    react是是 Facebook 推出的一个用来构建用户界面的 JavaScript 库。 React主要用于构建UI,很多人认为 React 是 MVC 中的 V(视图)。React 拥有较高的性能,代码逻辑非常简单,越来越多的人已开始关注和使用它。

    ReactJS是一套JavaScript Web库,由Facebook打造而成且主要用于构建高性能及响应式用户界面。React负责解决其它javascript框架所面对的一大常见难题,即对大规模数据集的处理。能够使用虚拟DOM并在发生变更时利用补丁安装机制只对DOM中的dirty部分进行重新渲染,React得以实现远超其它框架的速度表现。

    扩展知识:

    查找网上的React兼容IE8的方法,也发现不少的项目去兼容,而且都修改成功了,但我按照他们的修改方法去改我的框架的时候还是发现很多细节和他们的不一样。下面进行一个修改总结:

    一、按照官方微博的公布信息,支持ie8的最高版本是react@0.14版本,如果高于这个版本则是不兼容IE8的,所以得确定你使用的react版本不高于0.14。根据官方的说法,兼容的方法只需要在index.html中引入es5-shim.js和es5-sham.js(可以通过百度 搜索下载)这两个文件就行,这两个文件是一个将es5语法修改兼容es3语法的polyfill,但在项目实际添加了这两个文件后,还是会报一些错误。

    二、确保使用的Jquery版本是1.x.x的版本,IE8不支持Juqery2.x的版本。如果你使用了BootStrap框架,这个框架需要最低的Jquery版本是1.9以上。

    三、对于另外两个框架 ,我使用的是"react-redux": “^4.4.1”,“react-router”: “^1.0.3”。

    四、需要在package.json中加入以下的几个依赖包:

     "console-polyfill": "^0.2.2",
        "es5-shim": "^4.4.1",
        "eventsource-polyfill": "^0.9.6",
        "fetch-ie8": "^1.4.0",
       "babel-polyfill": "^6.7.4",

    加入以上几个依赖包后,在自己的前端程序入口的地方,把上面的几个安装包引入程序当中:

    require('es5-shim');require('es5-shim/es5-sham');require('console-polyfill');require('fetch-ie8');require('babel-polyfill');

    五、以上的步骤完成后,ie8还是会报错,主要是Object.defineProperty函数相关的错误。这个时候需要一个关键的步骤在package.json中加入

      "es3ify-loader": "^0.2.0",

    这是一个将es5、es6语法转换成es3语法的包,这个包不需要在代码中引入到程序中,而是当我们的APP.js打包完成后,再使用这个loader进行再次的打包,我的app.js是采用gulp打包的,但es3ify-loader 只能用webpack打包工具

    来进行调用,所以需要在项目目录安装webpack,输入命令:npm install -g webpack。同时在目录下创建webpack.config.js,里面内容是:

    var webpack = require('webpack');
     
    module.exports = {
        //页面入口文件配置,这里是用gulp打包出来的app.js
        entry: {
            index : './build/app.js'
        },
        //入口文件输出配置,这里需要设置对app.js打包后得到的文件名称
        output: {
            path: './',
            filename: 'bundle.js'
        },
        module: {
            //加载器配置,这里使用es3ify-loader对app.js进行再次打包;
            loaders: [
                 {
                    test: /\.js?$/,
                    loaders: ['es3ify-loader'],
                 },
            ]
        },
    };

    以上步骤完成后,在项目目录下输入命令:webpack 则会自动开始打包,打包后本级目录下会生成bundle.js;

    六、完成上述步骤后,就完成了React+Redux+Ruoter框架在IE8下的兼容性修改。这是我的完整修改过程,修改完成后程序顺利在IE8下运行起来了,由于整个前端编写的是一个单页应用,在IE8下页面切换刷新还是比较慢的。

    【相关推荐:javascript视频教程web前端

    以上就是react几支持ie8的详细内容,更多请关注php中文网其它相关文章!

    声明:本文内容由网友自发贡献,版权归原作者所有,本站不承担相应法律责任。如您发现有涉嫌抄袭侵权的内容,请联系admin@php.cn核实处理。
    专题推荐:React
    上一篇:es6字符串怎么去掉最后一个字符 下一篇:es6装饰器有什么用
    千万级数据并发解决方案

    相关文章推荐

    • react三种定义组件方法有什么区别• react兼容什么版本的ie• rxjs和react的区别是什么• react中usestate改变值不渲染怎么办• React不支持less文件怎么办
    1/1

    PHP中文网