• 技术文章 >后端开发 >PHP问题

    php可以安装多个版本吗

    长期闲置长期闲置2022-04-26 17:46:00原创156

    php可以安装多个版本。安装多个版本的PHP需要在同一IIS服务器上进行安装,必须按照“php.net”文档以及“IIS 7.0”和更高版本中描述的步骤进行安装,不能使用系统中的安装程序,因为系统中的程序不支持并行安装。

    本文操作环境:centos 7系统、PHP7.1版、Dell G3电脑。

    php可以安装多个版本吗

    可以安装多各版本的PHP。 需要注意的:在同一IIS服务器上同时安装多个版本的PHP,必须按照php.net文档IIS 5.1和IIS 6.0及IIS 7.0和更高版本中描述的步骤手动安装。

    PHP多版本安装步骤:

    一、php -v,查看当前版本

    二、安装PHP ./install.sh mphp,选择要安装的版本

    1、在/usr/local/nginx/conf 下会多一个enable-php**.conf的配置

    enable-php.conf是5.6版本

    enable-php7.2.conf是新安装的7.2版本

    15.png

    三、添加站点并在vhost中选择PHP版本,默认是5.6版本

    16.png

    四、重启 lnmp restart

    推荐学习:《PHP视频教程

    以上就是php可以安装多个版本吗的详细内容,更多请关注php中文网其它相关文章!

    声明:本文内容由网友自发贡献,版权归原作者所有,本站不承担相应法律责任。如您发现有涉嫌抄袭侵权的内容,请联系admin@php.cn核实处理。
    专题推荐:php
    上一篇:php连接mysql的方式之间有什么区别吗 下一篇:php怎么检测数组键存不存在
    千万级数据并发解决方案

    相关文章推荐

    • php怎么将空格转换成nbsp符• 一文深入了解 PHP 8 中的 JIT• php怎么只显示部分字符• php怎么关闭目录• php怎么去掉前后的逗号
    1/1

    PHP中文网