• 技术文章 >web前端 >前端问答

    es6兼容ie8吗

    长期闲置长期闲置2022-04-26 10:24:23原创265

    es6不兼容ie8,只在ie10、ie11中兼容了部分es6的API;实现兼容的方法:可以利用“babel-loader”在ie8中把es6的代码编译成es5执行,使用“npm install babel-loader”即可安装。

    本教程操作环境:windows10系统、ECMAScript 6.0版、Dell G3电脑。

    es6兼容ie8吗

    es6不兼容ie8

    IE浏览器不支持ES6的语法,只在IE10、IE11中支持了部分ES6的API,所以在IE浏览器中使用ES6需要把ES6的代码编译成ES5才能执行。方法也很简单,就是用babel-loader。

    目前,ES6(ES2015)这样的语法已经得到很大规模的应用,它具有更加简洁、功能更加强大的特点,实际项目中很可能会使用采用了ES6语法的模块,但浏览器对于ES6语法的支持并不完善。为了实现兼容,就需要使用转换工具对ES6语法转换为ES5语法,babel就是最常用的一个工具

    02.png

    babel转化语法所需依赖项:

    安装依赖

    npm install babel-loader @babel/core @babel/preset-env --save-dev

    配置config文件

    exclude表示不在指定目录查找相关文件

    【相关推荐:javascript视频教程web前端

    以上就是es6兼容ie8吗的详细内容,更多请关注php中文网其它相关文章!

    声明:本文内容由网友自发贡献,版权归原作者所有,本站不承担相应法律责任。如您发现有涉嫌抄袭侵权的内容,请联系admin@php.cn核实处理。
    专题推荐:ES6
    上一篇:es6怎么改变数组数据 下一篇:es6中yield的用法是什么
    VIP课程(WEB全栈开发)

    相关文章推荐

    • 【腾讯云】年中优惠,「专享618元」优惠券!• import as在es6中的用法是什么• es6与es5的构造函数有什么区别• map是es6中的方法吗• es6中symbol的用法是什么• es6怎么判断是否为数组
    1/1

    PHP中文网