• 技术文章 >web前端 >js教程

    jquery从哪个版本开始不兼容ie8

    青灯夜游青灯夜游2020-11-17 11:17:38原创54

    jquery从2.0.0版本开始不兼容ie8,不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE浏览器,建议使用原生JS或者Jquery1.x版本,例如Jquery1.12。

    【相关推荐:jQuery视频教程

    jQuery 是一个简洁而快速的 JavaScript 库,可用于简化事件处理,HTML 文档遍历,Ajax 交互和动画,以便快速开发网站。jQuery 简化了 HTML 的客户端脚本,从而简化了 Web 2.0 应用程序的开发。

    jQuery设计的宗旨是“write Less,Do More”,即倡导写更少的代码,做更多的事情。它封装JavaScript常用的功能代码,提供一种简便的JavaScript设计模式,优化HTML文档操作、事件处理、动画设计和Ajax交互。

    jQuery的核心特性可以总结为:具有独特的链式语法和短小清晰的多功能接口;具有高效灵活的css选择器,并且可对CSS选择器进行扩展;拥有便捷的插件扩展机制和丰富的插件。

    jquery从哪个版本开始不兼容ie8?

    jquery从2.0.0版本开始不兼容ie8,不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE浏览器,建议使用原生JS或者Jquery1.x版本。

    低版本jq在ie下不报错,高版本jq在ie下报错

    1.png

    查看2.0.0的源码,只有addEventListener,显然IE不支持这个方法,IE下添加事件监听需要用attachEvent

    2.png

    再看1.11.2的版本源码,有点长,做了对addEventListener的判断,不支持的话走attachEvent

    3.png

    当然这只是使用高版本jq报的第一个错误,事情走到这一步就已经明了了,查看jq官网对浏览器的支持 http://jquery.com/browser-support/

    我们找到这样一段话

    4.png

    英语不好,拿谷歌翻译了一下 :(Current-1)和Current表示我们支持浏览器的当前稳定版本及其之前的版本。 例如,如果当前版本的浏览器是24.x,我们支持24.x和23.x版本。

    最后一句话,想要支持ie6-8,使用jq1.12-.

    总结起来就是一句话:jQuery2.0.0版本没有attachEvent所以ie8下会报错(当然ie8下报错不止这一个原因,但这是要想修复高版本jq在ie8下报错首先要解决的问题,这回牵扯出一系列的ie8兼容问题,这些兼容问题jq1.12-已经解决了,官方推荐ie8下使用1.12还是有原因的)

    更多编程相关知识,请访问:编程视频!!

    以上就是jquery从哪个版本开始不兼容ie8的详细内容,更多请关注php中文网其它相关文章!

    本文原创发布php中文网,转载请注明出处,感谢您的尊重!
    专题推荐:jquery
    上一篇:jquery 怎么判断radio是否选中 下一篇:jquery如何处理ajax缓存问题
    第14期线上培训班

    相关文章推荐

    • jquery easyui和bootstrap的区别是什么• jquery 如何判断是否有某个属性• jQuery怎么获取元素的坐标?• jquery如何使用新元素来替换所选元素• jquery 怎么判断radio是否选中

    全部评论我要评论

  • 取消发布评论发送
  • 1/1

    PHP中文网